Clicking a Table entry hides the table. How do I do this?
Ninox Profile

I'm watching the NinoxUS videos. David shows clicking a table entry and when he does that his table disappears and only the form shows. How do I do that. When I do it my table is always on the left, his is hidden.1

Ninox Profile

Hmm.. I would be interested in that too!   I recall if you do not have access to the table at all.. it will auto hide..

Ninox Profile

If you move your cursor over the left edge of the form view, you should see the column width adjustment symbol. Click on the left edge and drag it all the so that it covers the table view. This change appears to stick even if you aren't in Admin mode.

Ninox Profile

Nope, that is not it, nor does that work to hide the table. Watch the "300.02 - Linking Master / Parent Tables" video at the 15:00 point and you will see that David clicks on a record and the table auto hides. How do I set up my database to do that?

https://www.youtube.com/watch?v=Iw18BMWSEyY&t=926s

Ninox Profile

LOL, Sorry Mr. K, you can lead a horse to water... I'm not going to make a video for you, but that's how you do it.

Ninox Profile

Sean, I do know what you are suggesting, but it is not the same as what David shows in the video. Watch the video and you will see. See my movie saved in Dropbox (link below). The table is still at the left, in David's video it autop-hides (completely).

https://www.dropbox.com/s/w8pt74ohzlwi3ri/Screen%20Capture%202019-06-28%20at%2007.47.29.mov?dl=0

Ninox Profile

Mr. K, I watched your video. I don't know why your Form view left margin isn't going all the way over. It does on my computer using Mac version of Ninox even when I put it in full screen mode.

Ninox Profile

When you said full screen that got me thinking. I have a 27" screen. I did more testing; in full screen, the form winow opens left and leaves more of the table exposed then when I'm not in full screen. That indicates to me that there is a limit to how wide the form screen will open. Then I tested by shrinking the overall width of my Ninox window, and then I can make the entire table "auto-Hide" when a click into the form.

Ninox Profile

@Mr. K... Ahh.. I misunderstood your comment.. I thought you were referring to hiding the table from the left navigation ...  never mind.. 

Ninox Profile

I think there are two ways to do this: One is to hide the left sidebar completely by dragging the spilt screen bar left all the way. Second way is that there's a "Hidden" checkbox when you go to Administration (wrench)/Data model, click on the table name, and that brings up the table opitions. The table options and the checkbox also appear when you create a new table.

Screen Shot 2019-06-28 at 12.09.31 PM

1 2
Reply